ODBC Call Fail

I am trying to make ODBC connection using:

  1. Primavera SDK

  2. XE in Oracle

  3. Microsoft for Oracle

but always connection failed. I have windows 7 Ultimate x64 and Primavera P6 V7 with Oracle XE

I already tried this to change the username and password in Primavera SDK and entered the username and password of the database creation (pubprm$pm & password) but I received the same error.

However, for the XE in Oracle and Microsoft for Oracle driver the connection test is successful during the creation using control panel/Administrative Tools/odbc (odbcad32.exe) but when trying to get the data using access or mequery I receive the same error of call fail/connection fail.

Also I tried to create the connection from with access but at that time the connection is not successful noting that I used the same setting while creating the same connection using control panel/Administrative Tools/odbc (odbcad32.exe)

I installed Windows XP mode and test that ODBC connection which work fine and access can read the tables even without changing the username and password from pupuser into pubprm$pm. The same test also is done using win 7 x32 virtaulbox with the same result and the connection can be made and access can read the tables.

I think there is something in Oracle ODBC files that is not compatible with x64.
Is it possible to use the microsoft provided ODBC driver SQL Server to connect to the XE database and if it possible what is the recommended settings to establish a workable connection?

If I upgrade XE to or or 11.2 does the conversion will run smoothly and does the ODBC will be working?

1 answer

ODBC and 64 bit OS is a source of confusion. Im not sure if this is your problem here but It's def worth to check it out.

If the app is 32bit WoW and ODBC is configured on a 64bit OS the app won't "see" the connection configured. There is an ODBC admin for the 32bit environment that can be used to configure a 32bit app visible connection. Naming of the different odbcadmin exe files is however a bit confusing.

For 64 bits connections; %WINDIR%\System32\odbcad32.exe
(this is the one you've used in your desctiption from contol panel)

For 32bit connections; %WINDIR%\SysWOW64\odbcad32.exe
Try to setup the connection using this one.

Hope this helps!