Using VBscript. Cannot load Access 2010 recordset - but can see database tables!

I have Access 2010 installed on Win8/64-bit machine. Am using a VBscript in a .HTA file. Trying to connect to .ACCDB using ODBC. I know I'm accessing the database as I am getting a field count corresponding to which ever table I use. Such as: SELECT * FROM tablename. I see this when I hit the breakpoint after my and sql, connection. HOWEVER, I ALWAYS GET A -1 FOR MY RECORD COUNT!!! I have no errors prior to the breakpoint. I am using a 32-bit HTA editor and have set up my DSN using the 32-bit ODBC interface in the control panel. My database and my HTA file are in the same directory. HELP PLEASE!!!!!!!!!!!!!

2 answers

Did you solve this John?

Please post full code (if still a problem) or solution (if solved).


Yes - solved. I am scripting an .HTA using vbscript with HTAEdit. The breakpoing wouldn't give me recordcount, eof, etc. However, when I plowed ahead I found that those properties/values were recognized by my Provider (connectString = "Provider=Microsoft.ACE.OLEDB.12.0; Data Source=" & myDataFile) - even though they didn't show in my debugger. Everything is fine!!